Email Delivery Issues

Resolved
Operational
Started 11 months ago Lasted about 3 hours

Affected

Echometer App
Updates
  • Resolved
    Resolved

    This incident has been resolved.

  • Monitoring
    Monitoring

    We implemented a fix and are currently monitoring the result.

  • Identified
    Identified

    We are aware of an issue impacting email deliverability and are working on a fix.