Echometer - Login issues – Incident details

Login issues

Resolved
Partial outage
Started over 2 years agoLasted about 1 hour

Affected

Echometer App

Partial outage from 4:54 PM to 5:56 PM

Updates
  • Resolved
    Resolved

    The fix went live and the issue is now resolved.

  • Identified
    Identified

    We identified the issue and implemented a fix. The rollout will begin shortly.

    Until the fix is live you can use an existing workaround:

    1. Visit https://my.echometerapp.com/login
    2. Login again

    After logging in again you should be able to continue your work.

    You can expect the fix to go live in ~30 minutes.

  • Investigating
    Investigating

    We are aware of issues trying to access Echometer and are currently investigating this incident.