Echometer - Some Emails are currently not being sent correctly – Incident details

Some Emails are currently not being sent correctly

Resolved
Partial outage
Started 28 days agoLasted 17 minutes

Affected

Echometer App

Partial outage from 8:55 AM to 9:08 AM, Operational from 9:08 AM to 9:13 AM

Updates
  • Resolved
    Resolved

    The issue seems to be resolved and all emails are being sent out correctly again. Please let us know if you notice anything that's off.

  • Monitoring
    Monitoring
    We implemented a fix and are currently monitoring the result.
  • Identified
    Identified

    We've identified the issue and are currently working on deploying a fix

  • Investigating
    Investigating
    We are currently investigating this incident.